首页 > 开发程序 > Ruby > 正文


Ubuntu上配置Ruby on Rails框架及RubyMine IDE开发环境

09-10 21:05:58   来源:   评论: 点击:

准备阶段的碎碎念 在virtualbox安装过程中由于这样那样的原因,产生许多坑。 坑1、 关于终端,一定要使用启动器打开 安装完虚拟机,进入系统,

准备阶段的碎碎念

在virtualbox安装过程中由于这样那样的原因,产生许多坑。

坑1、 关于终端,一定要使用启动器打开

安装完虚拟机,进入系统,我们便会遇到第一个坑,终端软件,建议大家都使用启动器打开终端,

千万不要使用文件管理器,进入文件夹,再右键“在终端中打开”,这个时候,环境变量加载不上,尤其在非桌面文件夹进入时。终端加载不上环境变量,大多的软件都没法在终端中执行。

打开终端时,一定要通过启动器,所谓启动器,就是在bantu中放在桌面左侧的侧边栏,很像windows中的快捷方式

坑2、 关于假设,大多数网站都假设你安装了一些基本包或者软件,但是有不提,这让初学者搭建环境尤其费力。

解决方法:手动安装软件,命令:

apt-get install 包名字

国内由于各种原因倒是软件安装超时。

你在下边安装过程中,若是出现了服务器积极拒绝,80%的可能行是被墙了。或者被你公司、家所在网络屏蔽掉了或是出现了速度很慢,半天不动的现象,恭喜你,你得换源地址了。

rvm解决方法:安装完rvm,确保rvm -v可以执行后,执行以下命令,替换服务器资源信息

sed -i -e's/ftp.ruby-lang.org/pub/ruby/ruby.taobao.org/mirrors/ruby/g'~/.rvm/config/db

gem 解决方法:

gem sourcegem source -r https://rubygems.org/gem source -a https://ruby.taobao.org/ //添加淘宝源

如果提示找不到安装包则手动更新随机自带的软件包:

sudo apt-get update

安装步骤

1.更新随机自带的软件包,这个是很必要的,否则下面可能产生N多错误

sudo apt-get update

2.安装curl,我们需要用它来装rvm

sudo apt-get install curl

3.安装rvm,我们使用rvm安装ruby、rails等,rvm安装参见:https://ruby-china.org/wiki/rvm-guide

curl -L get.rvm.io | bash -s stable//无法检查签名:找不到公钥,执行下边语句(是个坑)gpg --keyserver hkp://keys.gnupg.net --recv-keys 409B6B1796C275462A1703113804BB82D39DC0E3//然后,重新执行,安装完rvm之后,需配置终端,以便下次打开终端能直接只用rvm。更改终端配置方法:参见https://rvm.io/integration/gnome-terminalcurl -L get.rvm.io | bash -s stable//至此,rvm安装完成,下边我们手动为终端配置rvm环境,否则以后在终端中可能每次都要手动加载rvm环境//更改终端配置方法:工具栏--编辑--配置文件首选项--标题和命令--命令--选中“以登录shell方式运行命令”//然后,我们手动加载rvm环境,将服务器资源改为淘宝的///////$ source ~/.rvm/scripts/rvm 官方的加载rvm环境命令,我们就不执行了//临时加载rvm环境,参考:https://rvm.io/integration/gnome-terminalsource ~/.bashrcsource ~/.bash_profile//更改rvm源服务器资源信息,毕竟国外的经常被墙掉,还有就是国内的速度快。若不设置,下面可能出现各种问题,如出现服务器积极拒绝(被墙),或者下载速度慢sed -i -e 's/ftp.ruby-lang.org/pub/ruby/ruby.taobao.org/mirrors/ruby/g' ~/.rvm/config/db//请保存你的工作,然后重启ubuntu系统sudo reboot//重启完后,打开终端,我们便可以使用rvm了,//列出rvm远程服务器上都有那些可用的ruby版本rvm list known

4.安装ruby,我们选择最新的,不带版本号就是说装最新的,

rvm install rubyrvm use x.x.x --default //设置默认版本

如果提示

RVM is not a function, selecting rubies with 'rvm use ...' will not work.

则从新加载一下配置文件

source ~/.bash_profile

5.下边我们要用到gem,使用前,先切换到淘宝服务器 gem更多使用,参见://查看当前gem源列表,默认源是

https://rubygems.org/

6.使用gem安装rails

gem install rails //如果有问题 提示缺少什么依赖包就安装什么依赖包

然后就开始正式开始安装ruby on rails了

ruby -v//查看ruby版本rails -v//查看rails版本

版本没有问题就开始创建项目,此处省略100字。

项目创建完成后需要安装js编译器(有的时候需要 有的时候不需要 不知道为什么,保险起见,装上吧)

sudo apt-get install python-software-propertiessudo add-apt-repository ppa:chris-lea/node.jssudo apt-get updatesudo apt-get install nodejs

然后启动 

rails s

如果启动成功后,可以在http://localhost:3000查看网站


ubuntu下RubyMine的安装

1.官网下载JDK,解压

可以手动解压也可以使用命令行,感觉意思差不多。还是用鼠标爽一点感觉。

$tar -xzvf jdk-8u20-linux-x64.tar.gz

2.复制至usr/lib

一般还是习惯于放到这个目录下边,当然不是决定可以根据自己的环境选择存放目录

sudo cp-r ~/jdk1.8.0_20 /usr/lib/jvm

3.配置环境变量

sudo gedit ~/.profile

在文件末尾加上环境变量

export JAVA_HOME=/usr/lib/jvm/jdk1.8.0_20

然后保存并且更新后查看是否添加成功

source ~/.profileenv

出现JAVA_HOME 这个变量并且和添加的目录一致则表示环境变量修改成功

3.修改默认JDK

$sudoupdate-alternatives --install/usr/bin/java java /usr/lib/jvm/jdk1.8.0_20/bin/java300$sudoupdate-alternatives --install/usr/bin/java java /usr/lib/jvm/jdk1.8.0_20/bin/javac300$sudoupdate-alternatives --config java$sudoupdate-alternatives --config javac$ java -version //查看一下java版本 是不是新安装的版本

4.上网下载rubymine,然后解压,进入bin,运行./rubymine.sh打开。

叮。。。。完美。

相关热词搜索:Ubuntu Ruby on Rails RubyMine Ruby Linux

上一篇:Ruby on Rails框架程序连接MongoDB的教程 下一篇:最后一页
分享到: 收藏